Disable Automatic Update

Feb 19, 2012 at 11:32 PM

 

How do I set wabbitEMU to NOT check for updates?

 

There is no option in the menus that I can see.

 

I've tried adding 'groups.revsoft.org' to the host file to block checking, but that didn't work.

Developer
Feb 20, 2012 at 4:32 AM

Currently there is no option to disable checking for updates. Often I will use the update to patch certain issues and ensure I don't receive reports for bugs that have been fixed several versions ago. Wha treason do you have for not wanting to use the updater?

Feb 21, 2012 at 12:14 AM

I  have just started using wabbitEMU and installed it on several computers around the house... thinking this was a better solution than the VTI program I had been using.

It really should have an option to shutoff automatically chekcing for updates - on a dialup connection it takes quite awhile for the download to complete.

The program works just fine as is and if I find a bug I'll manually update the program as needed. The only problem I've seen so fa is when the 'cutout' skin is used the button presses don't flash... the solution is simple; don't use the 'cutout' skin! :)

It's annoying to have to either download or click 'no' when all I want to do is use the calculator for 5-seconds!  Clicking 'no' still asks next time program is launched.

Turning off updating needs to be a user option.

Developer
Feb 21, 2012 at 1:18 AM

Fair enough I'll put it in the next build. Unfortunately I'm in the middle of ripping apart the debugger, so it'll be another day or so.

As for the cutout skin not highlighting keys, its a technical limitation. Lower end machines were seeing a lot of slowdown when pressing several keys at once, so I disabled it.

Feb 23, 2012 at 2:15 PM

Hi BuckeyeDude,

I've just tried your last WabbitEmu version from yesterday,
and this release works great - and it's really fantastic
that it now also emulates the TI-81! :-)

There's only one small problem I've found:
If I turn on the option "Automatically turn on calculator",
then this feature works when I start WabbitEmu or when I
use 'File>New', but it does not work when I switch to an other
emulation with 'File>Open'.
The new opened calculator does not automatically turn on,
and it can't even be turned on manually in the Debug menu
when this option is activated.
Not a big deal, but maybe you can try to fix it.

Thanks again for your great work,
Franz

 

Feb 24, 2012 at 6:32 AM

 

Thanks for adding the option to turn off updates!