Wabbit code on windows

Aug 20, 2011 at 1:52 PM

I tested this IDE, but there is many many bugs !

First, when we launch WabbitCode :

-http://img851.imageshack.us/img851/2474/sansrevq.png

-If we launch wabbitcode and try to create new program, the program quit. We have to try another time

-If we try to assemble the program before saving it, it make an error instead saying "Where do you wish to save it ?"

-Many others bugs...

 

Enhancement :

-The Wabbitemu.exe inside isn't updated : If we change the .exe to the new version, Wabbitcode don't use this ! Please make he uses this one !

-Make the emulator directly launch the program instead sending it and the user have to launch it on emulator itself

 

PS: I'm glad to see the emulator coming on cydia for my iphone !

Developer
Aug 20, 2011 at 6:26 PM
Edited Aug 20, 2011 at 6:27 PM

The first error is because revsoft is down and I do a check for updates. Some of the other bugs I've been working on fixes for but I haven't had a lot of time to work with them. As for assembling a program before saving it, you have to save it to disk before spasm can use it. There are some ways around that but they are only for the most basic scenarios. This is true of any assembler or compiler.

For enhancements I know wabbitemu isn't updated and there is a reason for this. That version has an older COM interface that my code relies on. The new one I haven't quite got working yet. Also I believe there is an option to send directly to the emulator in preferences.

As for Wabbitemu for cydia don't hold your breath. I don't really do mac development and Will has no desire to do more work on it