Android Wabbitemu: Uploading .sav files for ROM file causes app to crash

Feb 18, 2014 at 6:04 AM
Hi,

I really like your work on the new Android version of Wabbitemu! A few days ago I tried to take the .sav file that I use on my Windows desktop version of Wabbitemu, and use it as my ROM for the Android version. When this happens, it causes the Wabbitemu to crash.

Also, just wondering: will Wabbitemu (all platforms) ever support the TI-84 Plus C Silver Edition?
Developer
Feb 18, 2014 at 10:53 PM
Hello,

Glad to hear you like the software. Currently only uncompressed save states from the PC will work on Android. By default, the desktop uses Zlib compression. There is a combobox when saving the state to change this. I'll work on fixing the crash with compressed savestates.

As for the 84PCSE yes, there is currently a beta of Wabbitemu with it supported. If you'd like to try it for the desktop, you can download it from here. If you'd like to try it for Android, you can get the beta by joining the google group, and then opt in here. It may take a little time after joining for Google Play to update Wabbitemu.

BuckeyeDude
Feb 19, 2014 at 2:07 AM
Edited Feb 19, 2014 at 2:08 AM
Awesome! Thanks.

I tried the 84PCSE on Windows, and it works well. Only thing that I noticed was that the numbers and text on the screen of the 84PCSE are a bit small and harder to read compared to the text on the 84SE. Any timeframe as to when it will be out of beta?

Also I was wondering how difficult it would be to make the Windows version of Wabbitemu DPI aware. Currently it's being scaled up on high DPI displays in Windows, resulting in a blurry UI. Hopefully this won't be too hard to fix.
Developer
Feb 19, 2014 at 3:15 AM
Screen size is definitely an issue for the 84PCSE, the screen gets scaled down from 320x240 to 230x155. Obviously this is a pretty big discrepancy. To fix this I'm working on making it so you can scale the Wabbitemu skin arbitrarily. With this change, I'll update the skins to double their resolution, which should fix the DPI upscaling problem as well.

As for when this will be released, it should be soon but I'm still working on debugger features for 84PCSE developers. I'm also still working on the skin resizing issue described above. I'm hoping to have it out within the next week.

Thanks for all your feedback.
BuckeyeDude
Feb 19, 2014 at 5:47 AM
Edited Feb 22, 2014 at 3:52 PM
Wow, that's quite soon! I was expecting a much longer timeframe.

Yeah, the screen being scaled down would explain the small text size.

For the DPI scaling, updating the resolutions of the skins will help, but I'm not sure you completely understood the issue. The application is not declared as DPI-Aware. On lower resolution screens this is not noticeable, but it is noticeable on higher resolution screens. As a result the menu's at the top, and the getting started UI and settings panel for the app are all blurry.

For more information about this see: http://msdn.microsoft.com/en-us/library/windows/desktop/dn469266(v=vs.85).aspx#comparison_of_dpi_awareness_levels

Lastly, another bug I noticed in the beta version, is that when you have a number ending in 0's such as "120", and you go to copy it, it only copies "12" and truncates last the 0.

Hope this helps.
Developer
Feb 25, 2014 at 5:44 AM
Thanks for the link. Actually making this DPI aware will take some time, but for the mean time I enabled the awareness, so it should look a little better. I've also fixed the bug copying numbers ending in 0. This version does contain skin scaling, so it should be pretty close to release, I just need a couple more days to test it. Available at: http://buckeyedude.zapto.org/Revsoft/Wabbitemu/Beta/Wabbitemu.exe

BuckeyeDude
Feb 27, 2014 at 5:40 PM
Edited Mar 2, 2014 at 7:44 PM
I tried the newest version that you just uploaded last night (1.8.2.26), and thought that I would just offer a few comments.
I'm sure that making the application DPI aware will take some time, but I think that by enabling the awareness as of now may cause some issues for uses. When you attempt to resize the calculator, the buttons no longer work and it looks like this:

https://www.dropbox.com/s/mgac9slwo5ou3co/Untitled.png


Also, these are just really small minor bugs, but you may be interested to know about them:
  1. If you look at the title bar icon in the top left of the screenshot, you may notice that it's not the same updated icon that is in the taskbar of the application
  2. If you look at the properties of the .exe file, the copyright date is still 2013 (once again extremely minor, doesn't affect the app at all)
  3. When trying to copy a decimal that is less that 1, it does not copy the decimal point. For example, I try to copy ".4" and it only copies "4" without the decimal point.
  4. When trying to copy a number such as "6.022e23" is copies only "6.022"
  5. When trying to paste a number with a decimal or a mathematical operation, it omits the operation or/and the decimal. For example trying to paste "3-2" results in "32"
  6. Also, the keyboard shortcut Ctrl V to paste does not work (it gets overridden).
I know that the paste function is new, but I'm not sure why there are all these digressions in the copy algorithm. In the older version, none of these copy issues existed.

Anyways, keep up the good work!