After a long time working, all of a suddent, Wabbitemu doesn't even open (Windows 8, ASUS core i5)

Nov 3, 2013 at 3:16 AM
I have been using Wabbitemu for a long time without any problems. It works like a charm. All of a sudden, it doesn't even open. Would this be due to a Windows 8 update? I downloaded the new 32 bit version with the same result and the 64 version with the same result. Any hints? Thanks
Developer
Nov 5, 2013 at 9:58 PM
Edited Nov 5, 2013 at 11:46 PM
Hello,

Sorry to hear you're having issues with Wabbit. I doubt that the issues is due to a Win8 update, most likely its associated with corrupt settings . I'd like you to export your Wabbitemu settings to back them up. You can do so by:
Pressing WinKey+R
Entering the following command:
regedit /e "%UserProfile%\Wabbitemu.reg" HKEY_CURRENT_USER\Software\Wabbitemu
This will export Wabbitemu.reg to your user directory (eg C:\Users[username]\Wabbitemu.reg). Can you upload this file so I can look at your settings? Hopefully I'll be able to recreate the issue keeping Wabbit from opening and fix it for future versions.

The next step is to clear these settings. You can do so by:
Pressing WinKey+R
Enter:
reg delete HKCU\Software\Wabbitemu
This will bring up a command prompt asking you if you are sure you want to delete these settings. Keep in mind that all your Wabbitemu settings will be lost. If you have exported the settings in the first step you can always re-add them. You can enter yes then enter to delete them.

Let me know if this allows you to open Wabbitemu you again. In theory, it should. These are the only pieces of information Wabbit permanently stores on your computer, so deleting them is like starting fresh. If this does not fix the issue I have a couple other things for you to try.

Thanks,
BuckeyeDude
Nov 6, 2013 at 3:09 PM
Thank you very much.

For some reason the command you told me to do to export Wabbitemu from the register didn't work but I got in and right clicked the wabbitemu key to export it. I have it on my desktop now. How do I upload it to you? I tried attaching it to thsi email but hotmail said that type of attachement is not allowed.

After downloading wabbitemu.exe to my desktop, I removed it from the register editor and now Wabbitemu is as good as new.

I have a question. Can I use Wabbitemu to have two emulators: one for the TI-83 and another for the TI-84?

Thanks again!


1) Subscribe to the Free Math Videos in my webpage to be notified about the latest videos:
Go to: http://www.professorserna.com/Free-Videos
fill out your Name, Email, Course, and click "Sign-Up".




Professor Serna
Cell 786-290-9100
www.professorserna.com
www.facebook.com/professorserna
www.youtube.com/professorserna
twitter: @professorserna




Nov 6, 2013 at 3:14 PM
Sorry for the email signature. I didn't intend to advertise my services.
Developer
Nov 6, 2013 at 11:42 PM
Good to hear its working again. You can send me the .reg file if you first zip it. Thanks again for the help.

In regards to using Wabbit for both the 83 and 84 yes, you definitely can. If you go File->New you can create a new version of the current calculator. You can then open your other ROM file and use the 83 and 84 at the same time. Keep in mind Wabbit will save the last open calculator, so if you want Wabbit to open a specific calculator, make sure you close that one last.

BuckeyeDude
Nov 7, 2013 at 10:40 PM
Ok.Let's see if it works this time. Otherwise, I think we can do it using my DROPBOX account