wabbitemu 1.5.7.7 cutout-skin does not shut down

Sep 18, 2011 at 8:04 PM

Hi,

I just installed the new 1.5.7.7 version of wabbitemu on my Win7/64bit PC an I ran into some odd behaviour.

First, the emulator did not show up on screen. The icon appeared on the taskbar alright, but nothing could be seen on screen. Possibly it was residing somewhere outside the screen boundaries. Eventually I decided to remove the wabbitemu registry entries to make a fresh start.

That worked. After having set up everything, I got the TI-84 skin on screen. I quickly configured the cutout-skin which I prefer. But when I clicked the skin's Close button, wabbitemu would not shut down. It just disappeared from the screen. The taskbar icon remained and when clicked upon, the skin reappeared. This did not happen with previous versions when the close button would shut down the application all together. With the cutout-skin disabled, the close button on the window bar works as expected: it shuts down the application. The exact same behaviour occurs with the TI-83 rom and skin.

Something to look into?

Stephan

Developer
Sep 19, 2011 at 1:07 AM
Edited Sep 19, 2011 at 1:20 AM
Hi StephanP,
Good find, I’ve got a fix for this bug. Should have an update for it in the next couple days. In regards to the emulator not first working, did you have a previous version of Wabbitemu installed? There seems to be an issue upgrading between a version released around December 27th and any current version, which has the same sort of symptoms as the problem you saw. However if you can cause it without an older version installed the problem might be more serious then that.
Thanks,
BuckeyeDude
 
Sep 19, 2011 at 5:22 AM
Edited Sep 19, 2011 at 5:26 AM

Hullo Buckeye,

The first problem did indeed occur with an update of a previous installation, but not as long back as you're suggesting. The existing install was the one from last may.

The difference with the december version I already experienced before. I believe this is when a switch was made from a config-file to (more) registry entries. That didn't hurt much at the time, other than that I had to reconfigure the emulator once again.

Cheers, Stephan

Developer
Sep 26, 2011 at 7:24 PM

Hmm I'll have to look into these broken registry entries more. I dont remember what I changed that caused issues upgrading but I do need to detect and fix them. I've released a new version that fixes your issue with closing the cutout skin. Let me know if you find any other issues.

Thanks,

BuckeyeuDude