Err:Validation for MirageOS

Aug 20, 2011 at 4:57 PM
Edited Aug 20, 2011 at 4:59 PM

I tried putting MirageOS on a downloaded ROM for the TI84+SE 2.43. When I go to run it, it starts to defragment but then it says ERR:VALIDATION.

EDIT: Same with Celtic III and TI's periodic table app.

Aug 20, 2011 at 7:22 PM

Did you create a rom using wabbitemu's open source boot page option? If so you'll probably need to do so again with the latest version. I found there was a part of it that was not yet coded that was required by the OS to run apps on the the 84s. You can do so by going help->rerun setup wizard and overwriting your old rom file. If you're using a real rom can i get the boot code number? You can find it by pressing mode alpha+s

Aug 22, 2011 at 2:25 PM
Edited Aug 22, 2011 at 2:26 PM

Well, as you know from Omni, I did use the open source boot page and I got that error. I just made a ROM from rom8x, however, and it won't even install the OS. Here's what I get:

 error (If the picture doesn't show up, here it is)

Boot code 1.02, base code 2.43.

I reran the setup using the latest version, and apps now work, however the error with my "real" ROM still persists.

Aug 23, 2011 at 6:59 AM

Once you got your two boot page appvars what did you do? Also did you try sending an OS to wabbitemu then doing a Debug->reset? Its possible you didn't include the OS upgrade when creating your ROM

Aug 23, 2011 at 9:08 PM

When I got them I opened up the command prompt, went to my rom8x directory, and entered "rom8x 84PBE -1 D84PBE1.8xv -2 D84PBE2.8xv" (just now). I've also tried many other variations but they all got the same result. The ROM itself is exactly 1MB in size, but the ROMs from open-source software are 2MB. rom8x also seems to think that I'm making an 83+ ROM.

Aug 24, 2011 at 3:19 AM

IIRC rom8x also takes an OS file which you are missing. Did you try dragging the OS file onto the screen and resetting the calc as I suggested before? You can also try using rom8x via wabbitemu startup wizard. Select the option to create a ROM from your calculator and ignore the step about sending the file to your calculator. When you created an open source did you select 84P or 84PSE? Its possible I don't create the ROM size possible but I didn't think so 

Aug 24, 2011 at 4:09 PM

The only 2.43OS I've found is TI's one for Singapore, so I tried sending that to Wabbit and the apps work fine (they worked when I updated Wabbit, too). I used that OS to make the ROM, too, and that's works now as well.

TI84+/SE ROMs from open-source now both work with apps, too.